Русскоязычное программирование (План А)

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



Как два байта записать

Сообщений 1 страница 2 из 2

1

использовать Файлы
алг
нач
файл ф
установить кодировку('CP-1251')
ф := открыть на запись ('ай-яй-йэ.батарейка')
вывод ф, символ(13)
вывод ф, символ(10)
закрыть (ф)
кон

Идея такая: генерируем бинарник, который использует системные вызовы (линукса) для работы с
1) файлами
одних только файлов достаточно, чтобы написать компилятор кумира на кумире.
2) сокетами
А если будут сокеты, то можно соединяться с X-сервером и рисовать IDE =)

Это вам не лисп какой-нибудь там!

0

2

TCP/IP sockets use file descriptors is that, when the sockets interface was first designed and implemented (in BSD Unix, in 1983), its designers felt that a network connection was analogous to a file - you can read, write, and close both, and that it would fit well with the Unix idea of "everything is a file".

https://stackoverflow.com/a/12112055/3161761

Even to master Xlib, you have to spent months or years! It's so intricate that almost every app that has graphical content to display uses a toolkit instead.

Using a plain socket means speaking the X11 protocol directly, which means you would end up recreating Xlib (no, you wouldn't finish!)

Отредактировано Лис (2017-10-09 15:01:26)

0